Configuration requise

De webtrees
Aller à : navigation, rechercher

Pour installer webtrees, vous avez besoin : d'un serveur, d'espace disque, de PHP et de MySQL.

  • Serveur - Apache, Nginx et IIS sont les plus couramment rencontrés. Aucune obligation de type spécifique ou de version n'est exigée.
  • Espace disque - Il faut environ 45Mo d'espace sur le disque dur pour les fichiers, quelquefois davantage pour vos fichiers multimédia, les fichiers GEDCOM et la base de données.
  • PHP - webtrees 1.7.1 nécessite version PHP 5.3 ou plus. La prochaine version de webtrees exigera au minimum PHP 5.4. Notez que de nombreux hébergeurs offre à la fois PHP4 et PHP5 avec, souvent, PHP4 par défaut. Si tel est le cas, vous devrez faire le changement par un panneau de commande en ligne ou un fichier de configuration. Consultez la documentation de votre hébergeur pour plus de détails.
    • PHP doit être configuré avec la librairie PHP/PDO pour MySQL. Il s'agit d'une option de configuration du serveur généralement activé par défaut (voir http://php.net/pdo).
    • PHP doit être configuré pour autoriser les ressources suffisantes du serveur (mémoire et temps d'exécution) pour la taille de votre système. Les exigences de base sont :
      • petits systèmes (500 personnes), 16-32 MB, 10-20 secondes ;
      • systèmes moyens (5000 personnes), 32-64 MB, 20-40 secondes ;
      • grands systèmes (50000 personnes), 64-128 MB, 40-80 secondes.
  • MySQL - La version MySQL 5.0.13. ou plus est recommandée. Notez que webtrees peut partager une seule base de données avec d'autres applications, en choisissant un préfixe de table unique lors de la configuration. Si vous avez la possibilité de créer plusieurs bases de données, vous pouvez en utiliser une unique pour webtrees et créer un nom d'utilisateur et un mot de passe pour votre généalogie.
  • Compatibilité des navigateurs. webtrees supporte l'utilisation de la plupart des versions actuelles des navigateurs open-source tels que Firefox, Chrome et Safari. Nous efforcerons de maintenir le support des autres navigateurs comme Opera et Internet Explorer, cependant pas pour les versions antérieures. Actuellement, plusieurs choses ne fonctionnent pas avec IE6 et quelques-unes aussi avec IE7. Nous recommandons fortement la mise à jour des vieilles versions de vos navigateurs le plus tôt possible. Nous sommes également au courant du fait que les navigateurs IE et Opera fournissent généralement un pauvre affichage des langues RTL, par conséquent, nous ne pouvons les recommander à ceux qui ont des sites utilisant des langues RTL.
Pages Lisez-moi
Licence
Introduction
Configuration requise
Installation
Mise à jour
Fichier gedcom
Sécurité
Backup
Convertir depuis PhpGedView
Modèle:Révision