System-Anforderungen

Aus webtrees
Wechseln zu: Navigation, Suche

Für die Installation von webtrees wird folgendes benötigt:

  • Ein Webserver - Apache und IIS sind gängige Typen. Es gibt keine Anforderungen an einen bestimmten Typ oder Version.
  • Etwa 45MB Festplattenspeicher - für die Anwendungs-Dateien, zzgl. was auch immer für Ihre Multimedia-Dateien, GEDCOM-Dateien und Datenbank benötigt wird.
  • PHP. webtrees 1.7.11 benötigt PHP-5.3. Falls Ihr Server nur PHP-5.2 erlaubt, müssen Sie die letzte webtrees Version 1.4.6 installieren. Beachten Sie, dass einige Internet-Provider sowohl PHP4 als auch PHP5 dabei oft mit PHP4 als Voreinstellung anbieten. Falls dies der Fall ist, können Sie bestimmt mit Hilfe eines Bedienfelds oder einer Konfigurationsdatei zwischen den beiden wechseln. Beachten Sie die Hilfe-Dokumentation Ihres Internet-Providers für weitere Informationen.
    • PHP sollte mit der PHP/PDO-Bibliothek für MySQL konfiguriert sein. Dies ist eine Option zur Server-Konfiguration. Sie ist standardmäßig auf den meisten Rechnern aktiviert. Siehe http://php.net/pdo
    • PHP sollte so konfiguriert sein, dass ausreichende Server-Ressourcen (Speicher und Ausführungszeit) für die Größe des Systems bereitgestellt werden. Typische Anforderungen sind:
      • Kleine Systeme (500 Personen): 16-32 MB, 10-20 Sekunden
      • Mittlere Systeme (5000 Personen): 32-64 MB, 20-40 Sekunden
      • Große Systeme (50000 Personen): 64-128 MB, 40-80 Sekunden
  • MySQL 5.0.13 oder höher - beachten Sie, dass sich webtrees eine einzelne Datenbank mit anderen Anwendungen teilen kann, indem während der Konfiguration ein eindeutiger Tabellenpräfix festgelegt wird. Wenn die Anzahl der Datenbanken nicht beschränkt ist, können Sie eine Datenbank nur zur Verwendung durch webtrees einrichten und einen eigenen Benutzer und Passwort für Ihre Genealogie erstellen.
  • Internet-Browser-Kompatibilität - webtrees unterstützt die Verwendung der aktuellsten Versionen von Open-Source-Browsern wie Firefox, Chrome und Safari. Wir werden unser Bestes geben, um andere wie Opera und Internet Explorer zu unterstützen, wenn auch nicht deren frühere Versionen. Gegenwärtig funktionieren viele Dinge nicht gut in IE6 und ebenso einige nicht in IE7. Wir empfehlen dringend diese veralteten Browser so bald wie möglich zu aktualisieren. Wir sind uns auch bewusst, dass IE right-to-left (RTL von-rechts-nach-links) Sprachen im Allgemeinen schlecht unterstützt, deshalb können wir ihn für Seiten mit RTL-Sprachen nicht empfehlen.
  • RTL Funktionalität - um Websites, die sowohl von links nach rechts als auch von rechts nach links laufenden Text enthalten (z.B. Englische Daten auf Hebräischen Seiten), anzuzeigen, benötigen Sie einen Browser, der Unterstützung für das HTML5-Attribut dir="auto" bereitstellt. Derzeit untersützt Internet Explorer (11 und älter) dies nicht.
  • HTML Frames - Beachten Sie, dass webtrees Cookies verwendet, um Login-Sitzungen zu verfolgen. Webseiten, die webtrees-Seiten innerhalb eines HTML-Frames verfügbar machen, werden beim Login mit den Versionen 7, 8 und 9 des Internet Explorer Probleme bekommen. IE-Benutzer sollten die Datenschutz-Einstellungen unter Extras – Internetoptionen für weitere Informationen überprüfen.
Lies mich Seiten
Lizenz
Einführung
System-Anforderungen
Installation
Updates
GEDCOM-Dateien
Sicherheit
Datensicherung
Konvertierung von PhpGedView
Vorlage:Überprüfung